Opened 10 years ago

Closed 10 years ago

#5685 closed bug (duplicate)

Invalid string argument in show doesn't degrade like jQuery Core

Reported by: Rwhitbeck Owned by:
Priority: major Milestone: 1.9.0
Component: ui.effects.* (individual effect) Version: 1.8.1
Keywords: show Cc:
Blocked by: Blocking:

Description

Take this example of jQuery Core getting a invalid string in .show().

$("#ID").show("SlowAsAFatCat");

Even with invalid string $.show() will still show the element with id of ID.

Example: http://jsbin.com/acoxe4

If jQuery UI is loaded onto the page the $.show() method in the effects library will take over as it thinks the invalid string is a effect. But if it can't find the effect to show it does nothing. It doesn't fall back to doing anything or it doesn't display a JavaScript error.

Example: http://jsbin.com/acoxe4/2

$.ui.show(); should provide the same consistent fallback as jQuery Core.

Change History (2)

comment:1 Changed 10 years ago by Scott González

Milestone: 1.next1.9

comment:2 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5456.

Note: See TracTickets for help on using tickets.