Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#5702 closed bug (worksforme)

Short disappearance of scrollData in IE

Reported by: dittodhole Owned by:
Priority: minor Milestone:
Component: ui.button Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

some code first:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN" "http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" >
<head>
	<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.js"></script>
	<script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.2/jquery-ui.js"></script>
</head>
<body>
<!--
				return typeof jQuery !== "undefined" && !jQuery.event.triggered ?
					jQuery.event.handle.apply( eventHandle.elem, arguments ) :
					undefined;
				in nth-cycle causes textbox to loose scrollData
-->
	<script type="text/javascript">
		$(document).ready(function() {
			var fooButton = $('#fooButton');
			fooButton.button();
		});
	</script>
	<div class="ui-widget ui-widget-content">
		<textarea rows="12" cols="20">
		Nordkorea ignoriert Friedenssignal aus SeoulzurückTrotz zuletzt wieder sanfterer Töne aus Seoul hat Pjöngjang in der innerkoreanischen Krise gestern mit 
		Nordkorea ignoriert Friedenssignal aus SeoulzurückTrotz zuletzt wieder sanfterer Töne aus Seoul hat Pjöngjang in der innerkoreanischen Krise gestern mit 
		Nordkorea ignoriert Friedenssignal aus SeoulzurückTrotz zuletzt wieder sanfterer Töne aus Seoul hat Pjöngjang in der innerkoreanischen Krise gestern mit 
		Nordkorea ignoriert Friedenssignal aus SeoulzurückTrotz zuletzt wieder sanfterer Töne aus Seoul hat Pjöngjang in der innerkoreanischen Krise gestern mit 
		
		</textarea>
	</div>
	<button id="fooButton">fooButton</button>
</body>
</html>

if you enter or leave the button, the scrollData gets lost for a short time. this is happening in IE only (tested with 8.0.7600.16385 32bit).

if there's enough hirarchie (wasn't able to isolate the real problem yet) with other elements, the scrollData and selection within a textarea even gets lost.

this issue (scrollData) and selection (not yet isolated) are both caused by elements with class 'ui-widget', which fired hover or click, only.

i did a screencast, which can be retrieved here: http://www.youtube.com/watch?v=fdhgomj4EaM

Change History (4)

comment:1 Changed 9 years ago by Jörn Zaefferer

Component: ui.coreui.button

Setting to ui.button as the button widget is involved somehow. No idea what this is actually about.

comment:2 Changed 8 years ago by bmsterling

I've tested this in all the IEs and with the example code provided I can not reproduce. I've seen the issue in the video before and in the case where I came across it it had to do with the CSS. Adding zoom:1 to the elements in the video most likely will fix.

A say we resolve as won't fix.

comment:3 Changed 8 years ago by Scott González

Resolution: worksforme
Status: newclosed

I can't reproduce with your example code either.

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.