Opened 9 years ago

Closed 9 years ago

#5722 closed bug (fixed)

Re-adding droppable() to generated content fails in IE

Reported by: vigo Owned by:
Priority: minor Milestone: 1.8.5
Component: ui.droppable Version: 1.8.2
Keywords: IE Cc:
Blocked by: Blocking:

Description

Steps to reproduce:

1) dynamically generate two arbitrary elements (e.g. via html()) 2) make the first element draggable, the latter droppable 3) re-create the two elements 4) repeat step 2 5) dragging the first element fails in MSIE6/7/8

Workaround: call droppable("destroy") between steps 2 and 3

(This might be a documentation issue)

Attachments (1)

dnd.html (1.2 KB) - added by vigo 9 years ago.
Sample file accompanying the "steps to reproduce"

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by vigo

Attachment: dnd.html added

Sample file accompanying the "steps to reproduce"

comment:1 Changed 9 years ago by vigo

Duplicate of ticket #5374, with a minimal (AJAX-less) testcase.

comment:2 Changed 9 years ago by reiern70

IMHO this is NOT a documentation issue: JQuery UI should detect replaced droppables are no longer part of the DOM tree and discard them (or at least do not produce an exception). Otherwise D&D becomes unusable for complex settings where many parts of a screen can be replaced/update via AJAX. This is exactly the use case I'm describing on ticket 5374. That is calling destroy on on draggables/droppables is not a valid solution for all cases.

comment:3 Changed 9 years ago by Scott González

Milestone: TBD1.8.5
Resolution: fixed
Status: newclosed

This was already fixed, it was a problem with the auto-destroy of widgets.

Note: See TracTickets for help on using tickets.