Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#5749 closed bug (worksforme)

Delay error in Chrome

Reported by: cnanney Owned by:
Priority: major Milestone: 2.0.0
Component: ui.sortable Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

When using Chrome, any click and drag action results in the element binding to the mouse and dragging, even if it is shorter than the delay time specified.

I've set up a page with code that reproduces the error, along with examples of the error here:

http://cnanney.com/test/sortable/

I've set priority to major, because I consider being able to set a delay so accidental sorting doesn't occur is very important.

Change History (3)

comment:1 Changed 6 years ago by Scott González

Milestone: TBD2.0.0

comment:2 Changed 6 years ago by mikesherov

Resolution: worksforme
Status: newclosed

Thanks for taking the time to contribute to the jQuery UI project! I can no longer reproduce the issue using the latest jQuery and jQuery UI. http://jsfiddle.net/Vpmu2/

If you can still reproduce it, please feel free to reply to this ticket with a test case showing the problem. Thanks!

comment:3 Changed 6 years ago by cnanney

Yes, the mouse binding issues seems to be fixed. However, in your jsfiddle test case, there is still the issue in Chrome when the sorted element jumps to the left when released, which it doesn't do on Firefox.

Note: See TracTickets for help on using tickets.