Opened 9 years ago

Closed 7 years ago

#5751 closed bug (invalid)

datePicker 1.82 & 1.73 in safari 4/x -5.x/Flash 10.1 shifts all flash content on page left when initialized

Reported by: frostywd Owned by: frostywd
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

This is very specific but after installing Flash 10.1 I see that a flash menu and picture gallery shift and jump to the left about 6-10 pixels in my case. Interestingly enough, clicking on the date field (causing the calendar to appear) puts everything back into it's place until the page is reloaded.

I've tracked the problem to one css field in the core.css:

.ui-helper-hidden-accessible { position: absolute; left: -99999999px; }

Commenting the above out fixes everything.

To verify it was only the datePicker, I comment out the function that initialized the dateField and the problem disappeared.

To be clear, this is only with Flash 10.1 & Safari on a Mac. Chrome and FF on the mac with the same 10.1 plugin work fine.

I've tried the webkit nightly build and the problem is still there.

Change History (4)

comment:1 Changed 9 years ago by Jörn Zaefferer

Component: ui.coreui.datepicker
Keywords: Flash 10.1 removed

Afaik this has nothing to do with Flash. I've seen the same issue elsewhere where no flash was involved. Need a simple testcase.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD1.11.0

comment:3 Changed 7 years ago by mikesherov

Owner: set to frostywd
Status: newpending

This code is no longer in datepicker, and we only support Safari 5.1 and 6.0 at this point. Please let us know if you are still experiencing this bug on the latest version of jQuery UI. Thanks again for contributing!

comment:4 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.