Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#5764 closed bug (duplicate)

Tab key navigation broken in modal dialog in IE8

Reported by: womp Owned by:
Priority: major Milestone:
Component: ui.dialog Version: 1.8.2
Keywords: ie8, tab, navigation, dialog Cc:
Blocked by: Blocking:

Description

Using the tab key to cycle through the elements of a modal dialog is broken in IE8. Tabbing off the last dialog element will not cycle back to the first dialog element, it is instead lost to the browser's toolbar.

Similarly, reverse navigation with shift-tab is also broken.

This is reproducible with IE8 on the dialog demo site.

Change History (4)

comment:1 Changed 9 years ago by tibi7000

In IE 8, keypress events don't get generated.

Maybe keydown should be used for tab navigation inside the Dialog.

Also, as it's stated in keypress API, for SHIFT+TAB a keypress event is not generated.

comment:2 Changed 9 years ago by Jörn Zaefferer

Component: ui.coreui.dialog

comment:3 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #3768.

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.