Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#5821 closed bug (duplicate)

Mixed button set mis-aligned in IE

Reported by: legsak1mbo Owned by:
Priority: major Milestone:
Component: ui.button Version: 1.8.2
Keywords: button alignment checkbox Cc:
Blocked by: Blocking:

Description

Creating a buttonset containing buttons and checkboxes causes the elements to be misaligned in Internet Explorer 7 & 8.

For example:-

	<script type="text/javascript">
	$(function () {
		$("#buttonset").buttonset();
	});
	</script>
		
		<div id="buttonset">
			<button>Button 1</button>
			<input type="checkbox" id="button-2" /><label for="button-2">Button 2</label>
			<button>Button 3</button>
		</div>

In Firefox and Safari the three buttons are aligned. In Internet Explorer the middle button is lower than the other two and is overlapped by the third button. As a work-around I've added style="top:-2px;padding:2px 0px;margin:0px;" to the label element. Curiously this seems to work perfectly on the "toolbar" button demo but copying that code I had the same problem as above.

Change History (2)

comment:1 Changed 9 years ago by Scott González

Component: ui.coreui.button
Resolution: duplicate
Status: newclosed

Duplicate of #5254.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.