Opened 9 years ago

Closed 6 years ago

#5823 closed bug (invalid)

onChangeMonthYear not working properly with minDate and maxDate

Reported by: remington Owned by: remington
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

onChangeMonthYear recives the wrong date when working with a restricted date range.

This only happens when you switch the year(selecting it from the drop-down list) and the selected month is out of the datepickers range (in the year you selected).

onChangeMonthYear recives as paraeters the newly selected year and the selected month (the date isn't in the allowed range). The datepicker displays a different month (the first or last within the alowed range)

Change History (3)

comment:1 Changed 6 years ago by Scott González

Milestone: TBD1.11.0

comment:2 Changed 6 years ago by mikesherov

Owner: set to remington
Status: newpending

Hi, Thanks for contributing! Could you possibly produce a jsfiddle.net or jsbin.com demonstration of the problem? I was unable to reproduce the issue myself.

comment:3 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.