Opened 9 years ago

Closed 6 years ago

#5845 closed bug (invalid)

IE Text Selection While Dragging (Dealyed / Distance Start)

Reported by: rogerkng Owned by: rogerkng
Priority: minor Milestone: 2.0.0
Component: ui.draggable Version: 1.8.2
Keywords: IE Selection on delayed/distance start Cc:
Blocked by: Blocking:

Description (last modified by mikesherov)

Dear friends,

I noticed in the delayed/distance start draggable feature, on dragging the IE text selection was enabled in the background ( selecting all the page while dragging the element around). To resolve this problem I've just added a little function (at the end of this note) right before/after enabled the feature on some target elements. This problem also happens in the Delayed Start Demo site from Jquery.

You could tune this solution to only disable the selection, during the dragging event, not "forever" as I did.

$('.target-elements').each(function(){
    this.onselectstart = function() { return false; }
})

Att, Roger

Change History (7)

comment:1 Changed 7 years ago by Scott González

Priority: trivialminor

comment:2 Changed 7 years ago by Scott González

Type: enhancementfeature

comment:3 Changed 6 years ago by Scott González

Milestone: TBD2.0.0

comment:4 Changed 6 years ago by Jörn Zaefferer

Type: featurebug

This isn't really a feature. Draggable should always prevent text selection while dragging.

Can someone on our lovely triaging team try to reproduce the issue?

comment:5 Changed 6 years ago by mikesherov

Description: modified (diff)

comment:6 Changed 6 years ago by mikesherov

Owner: set to rogerkng
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! I can no longer reproduce the issue using the latest jQuery and jQuery UI using the info provided. http://jqueryui.com/draggable/#delay-start

If you can still reproduce it, please feel free to reply to this ticket with a test case showing the problem. Thanks!

comment:7 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.