Opened 9 years ago

Closed 6 years ago

#5853 closed bug (worksforme)

dragging li between nested ul in IE behave unlike FF

Reported by: schnoerkel Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.sortable Version: 1.8.2
Keywords: Cc: thomas.gafner@…
Blocked by: Blocking:

Description

What I am doing is http://jqueryui.com/demos/sortable/#connect-lists but with the difference that the lists (here 2) are not in sequence but hierarchically arranged: This means I have the container ul list with each li having its own ul list of items. Like this I can and always could (already with older versions of jquery and sortable) achieve that the user could not only reorder items within each list, but also move items from one container to another and even move the whole containers (but not inside other containers).

All this is still working very well in FF - but not in IE 7/8: While dragging an item the item gets a certain offset and the according container is also moving! Then on release (drop) sometimes the container is moved and sometimes the item (well the container should not move at all) and with a flowing animation everything is arranged nicely and also the according handler to change the state on serverside is called correctly.

It is like in IE the container ul is handling animation event that is should not. The reason could be that the event handling of nested tags in IE is different to FF: But I expect jQuery and ui.sortable to encapsulate exactly this ascpect from my code.

So basically it is just the animation while dragging that is somehow wrong: Since I do not override any event that is triggerd during dragging I am quite sure there is a bug in the framework (also FF works perfectly).

Im not sure it is ui.sortable or ui.draggable or even one of the base libs.

Change History (3)

comment:1 Changed 8 years ago by David.Sullivan

I am also having this issue. Here is the forum post I made about this http://forum.jquery.com/topic/nested-sortable-erratic-behavior-with-ie

and here is a fiddle of the issue.

http://jsfiddle.net/DAElectric/kNQxB/24/

comment:2 Changed 6 years ago by Scott González

Milestone: TBD2.0.0

comment:3 Changed 6 years ago by mikesherov

Resolution: worksforme
Status: newclosed

Thanks for taking the time to contribute to the jQuery UI project! I can no longer reproduce the issue using the latest jQuery and jQuery UI. http://jsfiddle.net/AFN5a/

If you can still reproduce it, please feel free to reply to this ticket with a test case showing the problem. Thanks!

Note: See TracTickets for help on using tickets.