Skip to main content

Search and Top Navigation

#5878 closed bug (notabug)

Opened July 30, 2010 06:32AM UTC

Closed July 30, 2010 02:34PM UTC

Last modified October 11, 2012 09:15PM UTC

Is it a bug for datepicker when I want to create multiple datepicker?

Reported by: zbqworktest Owned by:
Priority: blocker Milestone:
Component: ui.datepicker Version: 1.8.2
Keywords: datepicker Cc:
Blocked by: Blocking:

When a new datepicker is created automatically, these dynamic datepicker can not work, but the old one is working. I have tried to re-bind the each field's behavior, but it still not work.

I'm not sure if you could understand my explains very much, but can you check the attachments please? I think you will know that via my codes.

Eager for your replies~

Attachments (1)
Change History (6)

Changed July 30, 2010 07:06AM UTC by scottgonzalez comment:1

resolution: → invalid
status: newclosed

You're essentially cloning an existing datepicker field, which we don't support. In the future if you're not sure if the problem you're having is a bug, please use the forums.

Changed July 30, 2010 07:15AM UTC by zbqworktest comment:2

Thank you for your comments, I'm sorry to use "Bug" tag.

If then, how can I do it if I want to create datepicker field dynamically? Can I Remove the datepicker event when I create a dom, and then init them all?

Changed July 30, 2010 07:35AM UTC by zbqworktest comment:3

resolution: invalid
status: closedreopened

I have use $('.datepicker').datepicker("destroy"); to Unbind the datepicker before cloning, but now the new problem is: when I click the later datepicker, all the data will be published to the first Datepicker

Changed July 30, 2010 08:08AM UTC by zbqworktest comment:4

Sorry, I think I know how to resolve it. Please close it, Thank you!

Changed July 30, 2010 02:34PM UTC by scottgonzalez comment:5

resolution: → invalid
status: reopenedclosed

Changed October 11, 2012 09:15PM UTC by scottgonzalez comment:6

milestone: TBD

Milestone TBD deleted