Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#5884 closed bug (duplicate)

Interactions: Replace usage of .data() with $.data

Reported by: Jörn Zaefferer Owned by:
Priority: major Milestone:
Component: ui.mouse Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

.data() has a lot of overhead by triggering various events. jQuery UI doesn't need those events, so replace all uses with $.data for better performance.

Using the mouse-component for now, as several interactions are affected. Should be handled as part of the interactions rewrite.

Change History (3)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by Scott González

Duplicate of #6172.

comment:3 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.