Opened 10 years ago

Closed 6 years ago

#5926 closed bug (wontfix)

Sortable: Relatively positioned elements disappear after sort in IE7

Reported by: manuelvanrijn Owned by:
Priority: major Milestone: 2.0.0
Component: ui.sortable Version: 1.8.4
Keywords: IE7, sortable, drag, drop Cc:
Blocked by: Blocking:

Description (last modified by Scott González)

When sorting a element containing a ui-widget-header and buttons, the buttons disappear after dropping.

Here's an example that works in firefox but doesn't in IE7.

I've managed to fix this bug by removing the position: relative from the class ui-button in jquery.ui.button.css

Example of the bug: http://jsbin.com/uziku3/6

Change History (9)

comment:1 Changed 10 years ago by Scott González

Component: ui.buttonui.sortable

The bug is in sortable, not button. Also, the .ui-button class has to be positioned in order for icons to work properly.

comment:2 Changed 10 years ago by Scott González

Description: modified (diff)
Summary: Buttons disappear after dropping (+FIX)Sortable: Relatively positioned elements disappear after sort

comment:3 Changed 9 years ago by casasoft

We are encountering the same problem. When using sortable with any item with a 'relative' position, it disappears!

comment:4 Changed 9 years ago by mike1286

I am experiencing this issue as well any known fixes to this yet? I am using a button in a sortable in IE7 and the button disappears after sortable() drop.

comment:5 Changed 8 years ago by Scott González

Milestone: TBD2.0.0

comment:6 Changed 8 years ago by mikesherov

Status: newopen

confirmed on latest: http://jsfiddle.net/XhVak/

comment:7 Changed 7 years ago by tj.vantoll

Summary: Sortable: Relatively positioned elements disappear after sortSortable: Relatively positioned elements disappear after sort in IE7

This only occurs in IE7, the issue is not present in IE8.

comment:9 Changed 6 years ago by Scott González

Resolution: wontfix
Status: openclosed

We're no longer landing bug fixes for IE7 and will fully drop support soon.

Note: See TracTickets for help on using tickets.