Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#5941 closed enhancement (duplicate)

add a method that does the equivalent of "refreshPositions : true"

Reported by: greenone Owned by:
Priority: minor Milestone:
Component: ui.draggable Version: 1.8.4
Keywords: refreshPositions Cc:
Blocked by: Blocking:

Description

right now if one has a dynamic setup where droppable and draggable are being used one has to use the refreshPositions option which is less performant since the possible drop targets are calculated on each drag-move.

In most cases that is not necessary since the programer can decide when the positions have to be refreshed. I assume that when the drag-process starts the possible drop target spaces are cached somewhere somehow. If one could have this cache rebuild by a method call this would be a very useful improvement.

example use case:

  • a tree is displayed
  • one drags a node in order to move it somewhere else
  • while hovering the dragged node over another the other node opens revealing new potential drop targets
  • now call "refreshPositions()" to make those newly revealed nodes potential drop targets

Change History (2)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #4911.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.