Opened 9 years ago

Closed 4 years ago

#5967 closed bug (patcheswelcome)

Mac Safari Draggable after Ctrl Click

Reported by: newbee Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.mouse Version: 1.8.4
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Scott González)

Ctrl+Click on Mac acts as right click, but is reported as left click in Safari.

My remedy is in $.ui.mouse._mouseDown, change:

btnIsLeft = (event.which == 1)

to:

btnIsLeft = ((navigator.platform.match(/mac|win|linux/i) || ["other"])[0].toLowerCase() == "mac") ? (!event.ctrlKey && event.which == 1) : (event.which == 1).

Change History (8)

comment:1 Changed 9 years ago by newbee

Sorry that the limit of attachment is so small, my recording is only 1M...

comment:2 Changed 9 years ago by Scott González

Component: ui.coreui.mouse
Description: modified (diff)

comment:3 Changed 8 years ago by Jörn Zaefferer

Resolution: worksforme
Status: newclosed

Looks like this was addressed in Safari itself, can't reproduce.

comment:4 Changed 8 years ago by Jörn Zaefferer

Resolution: worksforme
Status: closedreopened

Got that wrong. Ctrl+Click is not working properly. Right click (two-finger click) works fine...

comment:5 Changed 8 years ago by Jörn Zaefferer

Status: reopenedopen

comment:6 Changed 7 years ago by Scott González

Milestone: TBD2.0.0

comment:7 Changed 4 years ago by Scott González

The only solution I can think of (that doesn't include UA parsing) is listening for contextmenu occurring immediately after mousedown. This requires making the start phase asynchronous though, which will probably complicate the code quite a bit.

comment:8 Changed 4 years ago by Scott González

Resolution: patcheswelcome
Status: openclosed

After five years with only one report for this, I'm going to close as patches welcome. Safari causes way too many bugs for us to keep working around all these cases.

Note: See TracTickets for help on using tickets.