Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#5987 closed bug (duplicate)

Draggable doesn't use jQuery context.

Reported by: guscatalano Owned by:
Priority: minor Milestone:
Component: ui.draggable Version: 1.8.4
Keywords: draggable context Cc:
Blocked by: Blocking:

Description

If we have the situation mentioned here.

http://stackoverflow.com/questions/539504/run-jquery-in-the-context-of-another-frame

Where the frameset contains jQuery UI code and the draggable element is inside a frame. The Draggable code will bind the mouse to the frameset document, NOT the frame.

Ideally, if this is passed in.

$(panel, childFrame.document).draggable();

The mouse bindings should be done to the childFrame.document, not the frameset's document.

These are the lines that could be changed to use jQuery context. $(document) .bind('mousemove.'+this.widgetName, this._mouseMoveDelegate) .bind('mouseup.'+this.widgetName, this._mouseUpDelegate);

and $(document) .unbind('mousemove.'+this.widgetName, this._mouseMoveDelegate) .unbind('mouseup.'+this.widgetName, this._mouseUpDelegate);

$(document) should refer to the context passed in.

Change History (2)

comment:1 Changed 9 years ago by Scott González

Component: ui.coreui.draggable
Resolution: duplicate
Status: newclosed

Duplicate of #4908.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.