Opened 9 years ago

Closed 7 years ago

Last modified 6 years ago

#5990 closed bug (worksforme)

Binding click handler to buttonset button prevents GUI state from updating

Reported by: icfantv Owned by: icfantv
Priority: major Milestone:
Component: ui.button Version: 1.8.4
Keywords: buttonset, button, click, function, gui Cc:
Blocked by: Blocking:

Description

Creating a buttonset from a basic "list" of radio buttons works fine. The GUI updates appropriately when each button is clicked, i.e., when a different button is pressed, the old one visually returns to an unchecked state.

When you add a click handler to the buttons via jQuery, the UI state does not return to normal.

I have coded a workaround in the example but the code is commented out in the function to show the bug, and how to work around it.

See the example here (uncomment the function code to remove the bug):

http://jsbin.com/ehuso3

Change History (4)

comment:1 Changed 7 years ago by Scott González

Owner: set to icfantv
Status: newpending

I'm not seeing any problems in that fiddle. I cleaned up the whitespace in the JS panel for readability in case you want to take another stab at this: http://jsbin.com/ehuso3/92/edit

Perhaps the issue only exists in a specific browser or a different version of jQuery UI? You filed the bug against 1.8.4, but you're using 1.8.0 in the fiddle.

comment:2 Changed 7 years ago by icfantv

Status: pendingnew

Hey Scott. I see that this was reported 2 years ago and as you say, I was using the wrong version in my fiddle. 2 years ago I would have been using either Firefox or Chrome (if it was out) on Linux so if it's working now (and I just checked in the latest Chrome/Firefox on Linux and it is), I would say that if it's ok with you, we can just go ahead and close it out.

Does this sound acceptable?

comment:3 Changed 7 years ago by Scott González

Resolution: worksforme
Status: newclosed

Thanks for the info. I'll just close as worksforme since neither of us are able to reproduce it today.

comment:4 Changed 6 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.