Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#6003 closed bug (duplicate)

jQuery.ui.draggable is very slow while dragging over an iFrame in Firefox.

Reported by: KeithMajhor Owned by:
Priority: minor Milestone:
Component: ui.draggable Version: 1.8.4
Keywords: Firefox Slow jQuery draggable iframe Cc:
Blocked by: Blocking:

Description

That's pretty much it. Any draggable element, including sortable, is VERY slow while dragging over an iFrame in Firefox. Too the point where if you move the mouse too quickly it'll bug out.

Change History (5)

comment:1 Changed 9 years ago by rdworth

I propose the fix for this is to do away with the iframeFix option and build-in the behavior of it (which is to place a div over iframes during drag) being set to true, which is not currently the default.

comment:2 Changed 9 years ago by Jörn Zaefferer

We do that elsewhere anyway, right?

comment:3 Changed 9 years ago by rdworth

Elsewhere we place invisible iframes under divs, via bgiframe, but this is placing a transparent div over a visible iframe. I don't know of anywhere else we're doing this, unless it's done in some other drag-and-drop interaction, like sortable or resizable, and done differently than here. But it brings up a good point, this needs to be done every time the mouse is captured by the mouse widget. Maybe it should be done by the mouse widget.

comment:4 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #6004.

comment:5 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.