Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#6024 closed bug (duplicate)

copy/paste broken in datepicker attached to input field

Reported by: mikgan Owned by:
Priority: major Milestone:
Component: ui.datepicker Version: 1.8.2
Keywords: datepicker copy paste Cc:
Blocked by: Blocking:

Description

Hi guys,

I've come across a small problem using the datepicker from jquery-ui. Currently using 1.8.2. When attaching a datepicker to an input elements as below, the key bindings for copy and paste seem to be lost.

$(document).ready(function()

{

$('.datepicker').datepicker({ changeMonth: true, changeYear: true,

dateFormat: 'dd/mm/yy' });

})

<input class="datepicker" type="text" name="mydate" value="01/01/1981">

I suspect that this is because the use of keyboard shortcuts that are attached to the datepicker. Is there a way to via configuration disable the keyboard shortcuts? Or any other work around for this issue?

(This seems to have been reported a few years back by nathan.maves

@ http://forum.jquery.com/topic/copy-and-paste-in-datepicker-broken.)

Thanks in advance, Mik.

Change History (3)

comment:1 Changed 9 years ago by mikgan

oops, can close as duplicate of http://dev.jqueryui.com/ticket/5317

comment:2 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:3 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.