Opened 10 years ago

Closed 10 years ago

Last modified 7 years ago

#6061 closed bug (duplicate)

jquery.ui.tabs.js breaks when compressed with YUI Compressor (caused by non-breaking space character)

Reported by: stevekwan Owned by:
Priority: minor Milestone:
Component: ui.tabs Version: 1.8.4
Keywords: yui compressor yahoo Cc:
Blocked by: Blocking:

Description

When attempting to compress jquery.ui.tabs.js using Yahoo's YUI Compressor, the resulting minimized JavaScript does not render tabs properly. YUI Compressor is having difficulties minimizing this file because of an unusual non-breaking space character inside.

On line 606 of the uncompressed version of jQuery UI tabs, there is a non-breaking space character (hex code 0xA0). This is what's causing the YUI Compressor problems. The line reads:

load: function( index ) {

The space between "index" and ")" is actually a character with hex code 0xA0. I assume it should be a regular space. Replacing this character with a normal space fixes the problem, and allows the file to be compressed with the YUI Compressor.

This issue also appears in jquery.ui.core.js v1.8.4 on line 27. I've filed a separate bug report for this.

And yes, I know that I could just use the pre-compressed version of jquery.ui.tabs without any problems. :) But I'm working on a project that requires all JavaScript to be minimized and packaged together with the YUI Compressor.

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5921.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.