Opened 10 years ago

Closed 10 years ago

#6077 closed bug (duplicate)

JQuery UI doesn't work on Internet Explorer 9

Reported by: tperalta Owned by:
Priority: blocker Milestone: 1.9.0
Component: ui.mouse Version: 1.8.4
Keywords: IE9, Internet Explorer 9 Cc:
Blocked by: Blocking:

Description

The issue is caused by some detection code in jQuery UI that, if the browser is IE, checks the value of event.button in the mousemove event. In versions of IE previous to IE9 this property could be used to determine if the mouse button is still down, meaning the user is still dragging. The most common scenario where the inverse could be true is if the mouse button was released during a drag while the cursor was outside of the window, which in the same versions of IE does not trigger a mouseup. So this is detection code to make sure we handle that and don't continue a drag if the mouse button is not still down while the mouse was captured and is still moving.

Change History (1)

comment:1 Changed 10 years ago by rdworth

Component: ui.coreui.mouse
Milestone: TBD1.9
Priority: criticalblocker
Resolution: duplicate
Status: newclosed

Duplicate of #5370

Note: See TracTickets for help on using tickets.