Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#6101 closed bug (duplicate)

Focus management failures in modal Dialog

Reported by: pete_otaqui Owned by:
Priority: minor Milestone:
Component: ui.dialog Version: 1.8.5
Keywords: Cc:
Blocked by: Blocking:

Description

<html>
<head>
<!-- incude jquery-1.4.2 and jqueryui-1.8.4 with base theme -->
<script>
$(function() {
	var opts = {modal:true, autoOpen:false};
	var d1 = $('#dialog1').dialog(opts);
	var d2 = $('#dialog2').dialog(opts);
	$('#open1').click(function(ev) { d1.dialog('open'); });
	$('#open2').click(function(ev) { d2.dialog('open'); });
});
</script>
</head>
<body>
	<button id="open1">Open First Dialog</button><br />
	<input name="one" /><br />
	<input name="two" /><br />
	<div id="dialog1">
		<input name="three" /><br />
		<input name="four" /><br />
		<button id="open2">Open Second Dialog</button>
	</div>
	<div id="dialog2">
		<input name="fix" /><br />
		<input name="six" /><br />
		<p>Lorem ipsum dolor sit amet, consectetur
adipisicing elit, sed do eiusmod tempor incididunt ut labore
et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud
exercitation ullamco laboris nisi ut aliquip ex ea commodo
consequat. Duis aute irure dolor in reprehenderit in
voluptate velit esse cillum dolore eu fugiat nulla pariatur.
Excepteur sint occaecat cupidatat non proident, sunt in
culpa qui officia deserunt mollit anim id est laborum.
                </p>
	</div>
	
</body>
</html>

Firefox 3.6, OS X 10.6

  • tabbing only within first dialog correctly
  • extra tab stop on dialog itself with second dialog open, otherwise correct
  • keyboard navigation impossible after close of second dialog

Firefox 3.6, Win 7

  • tabbing only within first dialog correctly
  • extra tab stop on dialog itself with second dialog open, otherwise correct
  • keyboard navigation impossible after close of second dialog

Firefox 4b5, OS X 10.6

  • tabbing only within first dialog correctly
  • extra tab stop on dialog itself with second dialog open, otherwise correct
  • keyboard navigation impossible after close of second dialog

IE 9, Win 7

  • Tabbing cycles once then freezes even with 1 dialog open
  • Dialog closable with 'esc' or click
  • Same with 2 dialogs open

Chrome 7.0.517.8 dev, OS X

  • Tabbing cycles once then freezes even with 1 dialog open
  • Dialog closable with 'esc' or click
  • Same with 2 dialogs open

Chrome, Win 7

  • Tabbing cycles once then freezes even with 1 dialog open
  • Dialog closable with 'esc' or click
  • Same with 2 dialogs open

With Chrome and IE9 it seems that pressing tab never fires the "ui-dialog.keypress" event at all (other keys do).

Change History (3)

comment:1 Changed 10 years ago by pete_otaqui

This is *mostly* a duplicate of #5896, except for the comments on multiple dialogs

comment:2 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #3768.

comment:3 Changed 8 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.