Opened 10 years ago

Closed 10 years ago

#6116 closed bug (duplicate)

Datepicker: day with same day number as today is active in past and future months

Reported by: rdworth Owned by:
Priority: major Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.4
Keywords: Cc:
Blocked by: Blocking:

Description

This bug was introduced by #5676

See http://forum.jquery.com/topic/removing-highlighting-from-datepicker

Here's a workaround:

$("#datepicker").datepicker({
  onChangeMonthYear: function() {
    setTimeout(function() {
      $(".ui-datepicker .ui-state-active").removeClass("ui-state-active");
    }, 0);
  }
});

1.8.5 workaround demo: http://jsbin.com/owape4

As for the bug, here are minimal test cases:

1.8.2 (before) http://jsbin.com/owoxa4

1.8.4 (after) http://jsbin.com/eyedu3

Steps to reproduce

  1. Click in the text box to open the datepicker
  2. Click forward a month or back a month
  • Expected behavior: no dates are active
  • Actual behavior: the day with the same day num as today's date is active

Change History (1)

comment:1 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #5984.

Note: See TracTickets for help on using tickets.