Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#6129 closed bug (duplicate)

Dialog buttons are now created as type="submit" rather than "button"

Reported by: martinf55 Owned by:
Priority: major Milestone:
Component: ui.dialog Version: 1.8.5
Keywords: button Cc:
Blocked by: Blocking:

Description

The update to ui.dialog in 1.8.5 now creates the dialog buttons as <button></button> (line 364). This causes any form on the page to submit automatically. Prior versions up to 1.8.4 created the buttons as <button type="button"></button>, which had no side-effects. Since the type attribute cannot easily be changed after dialog creation, this is a quite a breaking change.

Change History (2)

comment:1 Changed 10 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #6128.

comment:2 Changed 8 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.