Opened 9 years ago

Closed 9 years ago

#6148 closed bug (fixed)

Tabs: Hover state sticks in Firefox if a field is focused on show

Reported by: shadwdrgn Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.tabs Version: 1.8.5
Keywords: Cc:
Blocked by: Blocking:

Description

show: function(event, ui) {

if (ui.panel.id == "tab2") {

$(ui.panel).find("#url").focus();

}

This code causes the tab loaded to stay highlighted after clicking off of it again as though the mouse was still hovering over it.

Example of problem at http://1dl.us/

Change History (7)

comment:1 Changed 9 years ago by shadwdrgn

After going to the website click on "shorten url" then click on any other tab. This will replicate the bug.

comment:2 Changed 9 years ago by Scott González

Resolution: worksforme
Status: newclosed

Works for me. Tested in Chrome, Firefox and IE.

comment:3 Changed 9 years ago by crumbles

Resolution: worksforme
Status: closedreopened

Scott,

It does not work. You didn't pay attention close enough to the issue. Please re-read and test again.

Go to the site: http://1dl.us - click on the shorten url tab, then click on any other tab. You will notice the tab stays dark and the hover effect stops working. If you click on that tab and then click on space in that tab (other than in the <a> anchor) then click on another tab, the effect unsticks.

comment:4 Changed 9 years ago by shadwdrgn

EXACTLY how to replicate (DO NOT click anywhere but where this tells you: 1) Go to http://1dl.us/ in firefox in windows OR linux. 2) Click on the "Shorten URL" tab. 3) Click on the "Info" tab.

Screenshots below: Here is a screenshot of the bug: http://1dl.us/128629796288187.png

In another screenshot ( http://1dl.us/128629800895854.png ) notice the "Read EMail" AND "Shorten URL" tabs are BOTH highlighted. That is because my mouse is over "Read EMail" and the bug keeps "Shorten URL" highlighted.

Here's a screenshot from a friend of mine's PC: http://1dl.us/128629827488699.jpg

comment:5 Changed 9 years ago by Scott González

Summary: Tabs hover effect sticking on focusTabs: Hover state sticks in Firefox if a field is focused on show

comment:6 Changed 9 years ago by Scott González

I'm still having trouble reproducing this on your site. I've tested Firefox on Windows and OS X.

comment:7 Changed 9 years ago by Scott González

Milestone: TBD1.9
Resolution: fixed
Status: reopenedclosed

I was able to build a reduced test case that showed the problem. The problem still exists in 1.8.13 but not in master.

Note: See TracTickets for help on using tickets.