Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#6159 closed bug (worksforme)

Buttonset borders have gaps

Reported by: icfantv Owned by:
Priority: minor Milestone:
Component: ui.button Version: 1.8.4
Keywords: buttonset, border, margin, gap Cc:
Blocked by: Blocking:

Description

See http://forum.jquery.com/topic/radio-buttonset-scaling for more info.

See http://jsbin.com/eweno3 for example of problem. Notice the gaps between the button borders.

Change History (5)

comment:1 Changed 9 years ago by Scott González

Resolution: worksforme
Status: newclosed

Works for me. Here's a screenshot of that jsbin demo in Chrome, Firefox and IE6: http://gyazo.com/c0ab15f209b4484e4a77d518f7e569d1.png

comment:2 in reply to:  1 Changed 8 years ago by glenvan

Replying to scott.gonzalez:

Works for me. Here's a screenshot of that jsbin demo in Chrome, Firefox and IE6: http://gyazo.com/c0ab15f209b4484e4a77d518f7e569d1.png

Try this. If the container font-size is something regular like 10px, then the .ui-button-set .ui-button's right margin setting of -0.3em is reliable. Change the font units here and there, and gaps start to appear.

I find that a .ui-widget font-size of 9pt (or 1.0em in a container using 9pt) is most problematic.

http://jsbin.com/eweno3/13

I'm using FireFox 3.6 on Windows (note that I'm using Trebuchet MS, which seems particularly fussy), but Safari 5 and Chrome 11 are both having issues.

Last edited 8 years ago by glenvan (previous) (diff)

comment:3 Changed 8 years ago by icfantv

I can no longer reproduce either. Given that 7 months in software is a lifetime, I think closing the ticket is sufficient however, I'm confused as to why it was closed shortly after I opened it considering there was evidence that it was an issue. I suspect scott never tried changing font sizes or the font face.

comment:4 Changed 8 years ago by Scott González

It was closed because I couldn't reproduce it. I did try scaling the fonts, this is all documented in the thread that's linked to from the ticket description.

comment:5 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.