Opened 10 years ago

Closed 6 years ago

#6177 closed bug (fixed)

Effects won't animate if there's a > selector

Reported by: hobarrera Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.effects.* (individual effect) Version: 1.8.5
Keywords: Cc:
Blocked by: Blocking:

Description

With this code:

#contact > .myDiv {
	height: 478px;
}

<div id="contact">
  <div class="myDiv">
  </div>
</div>


var mydiv = ...
mydiv.show('blind', 'slow', function() {....

mydiv is shown, but not animated.

If I change to code to:

#contact > .myDiv {
	
}

<div id="contact">
  <div class="myDiv" style="height: 478px;">
  </div>
</div>


var mydiv = ...
mydiv.show('blind', 'slow', function() {....

It animates correctly. This seems to be reproducible every time that the attributes that need to be modified for animating is defined in a CSS selector with a ">". (and it's not limited to blind).

Change History (6)

comment:1 Changed 10 years ago by Scott González

This is because the animated element has to be wrapped during the animation, so the selector no longer finds the element being animated.

comment:2 Changed 9 years ago by Corey Frang

comment:3 Changed 9 years ago by Corey Frang

Status: newopen

I'm not sure if we will ever be able to do anything about this problem. Going to leave it open a while longer...

comment:4 Changed 8 years ago by Scott González

Milestone: TBD1.10.0

comment:5 Changed 7 years ago by tj.vantoll

Milestone: 1.10.0none

comment:6 Changed 6 years ago by mikesherov

Milestone: none1.9.0
Resolution: fixed
Status: openclosed

This was fixed somewhere in the jQuery UI 1.9 series

Note: See TracTickets for help on using tickets.