Opened 9 years ago

Closed 7 years ago

#6178 closed bug (duplicate)

Datepicker keyboard shortcut not working

Reported by: daes20 Owned by:
Priority: major Milestone: 1.11.0
Component: ui.datepicker Version: 1.7.3
Keywords: Cc:
Blocked by: Blocking:

Description

I'm using the jQuery Datepicker with an icon trigger. I am having an issue with a keyboard shortcut not working and went to the demo for the Datepicker at http://jqueryui.com/demos/datepicker/#icon-trigger and found that it has the same issue. After a date has been selected from the calendar and the date textbox has been populated, if I click on the icon to open the calendar and using the keyboard shortcuts, select a day in the same month that is after the date previously selected and press enter, the date displaying in the textbox does not change and the date selected in the calendar does not change. I can use the shortcuts to select a day previous to the date already selected in the same month and also select a different day in another month (before or after the current month). I'm only having trouble if I want to choose a future day in the same month. Is there a setting that I can change to allow a future selection in same month?

Change History (2)

comment:1 Changed 7 years ago by Scott González

Milestone: TBD1.11.0

comment:2 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #5527.

Note: See TracTickets for help on using tickets.