Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#6187 closed bug (duplicate)

Autocomplete's option minLength not always respected

Reported by: matthew_be Owned by:
Priority: major Milestone:
Component: ui.autocomplete Version: 1.8.5
Keywords: Cc:
Blocked by: Blocking:

Description

It may happen that Firefox (3.6.10) executes "source" function only when minLength + 1 characters have been typed.

Change History (4)

comment:1 Changed 9 years ago by Scott González

Resolution: worksforme
Status: newclosed

Works for me.

comment:2 Changed 9 years ago by kopa

Resolution: worksforme
Status: closedreopened

i can reproduce this behaviour in google chrome (jquery-ui-1.8.4): (minLength: 3)

  • first input of 3 characters after a refresh:
    • source event is triggered
  • delete all characters and type 3 characters
    • source event is not triggered
  • add another character (lenght now = minLength + 1):
    • source event is triggered
  • delete last character so that 3 characters are left:
    • source event is triggered

comment:3 Changed 9 years ago by Scott González

Resolution: duplicate
Status: reopenedclosed

Duplicate of #5922.

comment:4 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.