Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#6253 closed bug (duplicate)

Button type changed?

Reported by: tinonl Owned by:
Priority: minor Milestone:
Component: ui.dialog Version: 1.8.5
Keywords: Cc:
Blocked by: Blocking:

Description

I have a regular form in the page and a onSubmit routine attached to my form. Upon submitting form is handled in the onSubmit routine. If there are any errors, I use the ui dialog as a modal popup to inform the users about this error; the user can click "ok" to close the dialog. Copy code1.$('#dialogError').dialog({

autoOpen: false, width: 300, height: 200, modal: true, resizable: false, buttons: {'Ok': function() {$(this).dialog('close');}} });

In 1.8.2 the button in the modal dialog has type="button". In 1.8.5 the button has type="submit". This results in an infinite loop, because closing the dialog also submits the underlying form, re-validating the page etc.

Is it behaviour by design that the dialog holds submit buttons instead of regular buttons?

Change History (2)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

Duplicate of #6128. In the future, please do not open tickets to ask questions. If you're unsure if something is a bug, please ask on the forums before filing a ticket.

comment:2 Changed 7 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.