Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#6261 closed bug (duplicate)

problem with draggable/sortable list in tabs

Reported by: badtwin Owned by:
Priority: minor Milestone: 1.8.11
Component: ui.sortable Version: 1.8.6
Keywords: draggable sortable Cc:
Blocked by: Blocking:

Description

When two unsorted lists (the first is .draggable(), the second is .sortable()) are connected, the drag/drop-effect only works, when an element of the target-list (the one with .sortable()) is dragged and dropped before once. else no elements from the first list (with .draggable()) can be dropped in the target-list.

When those lists are outside of the tabs, or on the first tab everything works like a charm.

Demo: http://jsbin.com/izamo4/3

Tested with chrome and firefox

Change History (5)

comment:1 Changed 8 years ago by aheywood

I'm experiencing this problem as well. I also found the problem occurring when the connected draggable and sortable are not inside a tab page as well.

I have a work-around that fixes this issue for me. In the start event of my draggable, I call the refresh method of the sortable.

$( ".draggable-class-name").draggable({
    connectToSortable: ".sortable-class-name,
    // other options here
    start: function(event, ui) {
        $( ".sortable-class-name" ).sortable("refresh");
    }
});

Hope this helps someone else struggling with this issue.

comment:2 Changed 7 years ago by Corey Frang

Status: newopen

http://jsbin.com/izamo4/9/ - Added the "expected" behavior on tab 0 to further show the "broken" behavior on tab 0...

comment:3 Changed 7 years ago by aheywood

This problem appears to be fixed in Jquery UI 1.8.11. See here for an example: http://jsbin.com/izamo4/10/ and here for the 1.8.11 release notes: http://jqueryui.com/docs/Changelog/1.8.11

comment:4 Changed 7 years ago by rdworth

Component: ui.tabsui.sortable
Milestone: TBD1.8.11
Resolution: duplicate
Status: openclosed

comment:5 Changed 7 years ago by rdworth

Duplicate of #5563.

Note: See TracTickets for help on using tickets.