Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#6668 closed bug (worksforme)

Accordion: input behaviour

Reported by: edwinboersma Owned by:
Priority: minor Milestone:
Component: ui.accordion Version: 1.8.5
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

I have an accordion with input fields in each row. The inputs are equipped with: $('#accordion').find('input').focus (function (e) { e.stopPropagation(); });

I can tab through the inputs and fill in values, but when a value exists in the input field, it starts showing odd behaviour:

  • when clicking the input field, I can place the caret in the text. Del and Backspace function correctly, but when pressing left or right arrow, the input looses focus and the cursor is to the arrow image at the beginning of the row (or any other row). It should of course just move the caret in the text.
  • after the above has happened (even if the input was empty), the input field doesn't get focus any more when tabbing, but the focus goes to the next empty input field.

It's not so much as unworkable, but rather annoying and hard to explain the the users.

Edwin Boersma

Change History (3)

comment:1 Changed 8 years ago by edwinboersma

By extending the "stopPropagation" to pressing the arrow keys (37 to 40), the behaviour becomes as expected. Not a bug though, but still I would opt for building in stopPropagation as default when arrow keys are pressed:

$('#accordion').find('input').keydown (function (e) {

if (e.keyCode >= 37 && e.keyCode <= 40) { e.stopPropagation(); }

});

Last edited 8 years ago by edwinboersma (previous) (diff)

comment:2 Changed 8 years ago by Scott González

Resolution: worksforme
Status: newclosed

This is working fine for me. Please provide a reduced test case showing the problem.

comment:3 Changed 6 years ago by Scott González

Milestone: TBD

Milestone TBD deleted

Note: See TracTickets for help on using tickets.