Opened 8 years ago

Closed 8 years ago

#6705 closed bug (worksforme)

no change event fired

Reported by: pmithrandir Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.6
Keywords: Cc:
Blocked by: Blocking:

Description

Hello

I try to get the change event works but it doesn't seem to be the case : (I reduced the code to focus on both events, close and change)

    $("#geo_location_locale").autocomplete({
        minLength: 3,
        //define callback to format results
        source: function(req, add){
            //pass request to server
            //some code are here
        },
        //define select handler
        select: function(e, ui) {
            //some code are here
        },
        close: function(event, ui) {
            $(this).val("fired");
        },
        change: function(event, ui) {
            $(this).val("never fired");
        }

    });

When I track my code, I get the close event, but not the change event. The problem is that they are simikar for some stuff but not for others, so I really need to get the change event fired.

I test with firefox 3.6.12. Ia tested with : jquery 1.3.2min.js jquery 1.4.2.js jquery ui 1.8.2.js jquery ui 1.8.6.js

Do you have any idea of the problem ?

Thanks Pierre

Change History (1)

comment:1 Changed 8 years ago by Scott González

Resolution: worksforme
Status: newclosed

Works for me. Make sure you tab out of the field to invoke the change: http://jsbin.com/igaco3

Note: See TracTickets for help on using tickets.