Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6730 closed bug (duplicate)

Autocomplete does not work on Firefox(3.6.12) while you type chinese word into the field by Chinses PinYin IME

Reported by: ery Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.6
Keywords: Cc:
Blocked by: Blocking:

Description

Environment:
OS: Windows7
Browser: Firefox(3.6.12)
IME: Chinses Sogou PinYin IME

First Get Testcase:
Get testcase from here. http://www.box.net/shared/a3c2asn5to
Testcase include:
video.demo.swf --- video demo
readme.txt --- description
test.app.js --- user javascript
test.fom.htm --- user html page
jquery-1.4.4.js
jquery-ui-1.8.6.custom.js
jquery-ui-1.8.6.custom.ui-lightness.css

Steps to Reproduce:
Step 1 open test file 'test.fom.htm' with Firefox(3.6.12).
Step 2 type 'c' into the field, after type Autocomplete widgets provides suggestions, it is correct.
Step 3 swich Chinses Sogou PinYin IME.
Step 4 type '周' into the field, after type Autocomplete widgets did not provides suggestions, it is incorrect!![[BR]]

Expected:
Autocomplete widgets provides suggestions, while user type Chinese word into the field, with Chinses Sogou PinYin IME and Firefox(3.6.12).

Actual:
Autocomplete widgets did not provides suggestions, while user type Chinese word into the field, with Chinses Sogou PinYin IME and Firefox(3.6.12).

Important Reminder:
1:Chinses word '周' is composed of 4 english words 'z,h,o,u'.
2:Chinese sogou IME is a popular PinYin IME in china,
and you can get it form here http://ime.sogou.com/dl/sogou_pinyin_51e.exe or here http://pinyin.sogou.com/
3:I also test with other Chinese PinYin IME as "Microsoft PinYin ABC", "QuanPin", I found Autocomplete still does not work.
4:I also test with IE8, Oper(10.63). I found Autocomplete can work on IE8 and can not work on Opera(10.63).

Reference:
http://jqueryui.com/demos/autocomplete
http://bugs.jqueryui.com/ticket/5933
https://forum.jquery.com/topic/autocomplete-does-not-support-non-english-characters

Change History (3)

comment:1 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

I'm not sure why you opened this ticket when you already saw that #5933 was closed as won't fix. Unless someone has an actual solution to this, we're not going to investigate any further.

comment:2 Changed 9 years ago by Scott González

Duplicate of #5933.

comment:3 Changed 9 years ago by ery

I report this ticket, have tow reasons.
First I think #5933 description not very clear, so I try to provide a clear one.
Second I think this bug is very very serious for chinese user.

I feel so sad since you close it as won't fix.
But I can understand your position.
But I still hope someday someone can help us with this bug.

Best Regards to you!

Note: See TracTickets for help on using tickets.