Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6731 closed bug (duplicate)

Incorrect datepicker parseDate when date format has single "y"

Reported by: maxbarbul Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.6
Keywords: Cc:
Blocked by: Blocking:

Description

When date format has single "y" and year is greater than 2020 DP parses date incorrectly.

Steps to reproduce:

  1. Open http://jqueryui.com/demos/datepicker/#date-formats
  2. Choose "Medium - d MM, y" format
  3. Insert "31 December, 20" or select 31 of Dec 2020 via datepicker. (Calendar shows correct date)
  4. Select the next day (1 of Jan 2021).
  5. Open calendar

Expected result: calendar shows 1 of Jan 2021 Actual result: calendar shows 1 of Jan 1921 (see attached image)

Change History (3)

comment:1 Changed 9 years ago by maxbarbul

See steps on this picture

http://lh3.ggpht.com/_HC7KzrUqMsI/TP9Qq2GUz1I/AAAAAAAAAsM/OHmgBpMDMbA/s800/ui.datepicker.parseDate.bug.png

comment:2 Changed 9 years ago by Scott González

Resolution: duplicate
Status: newclosed

comment:3 Changed 9 years ago by Scott González

Duplicate of #6659.

Note: See TracTickets for help on using tickets.