Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6741 closed bug (duplicate)

Dialog overlay dissapears by closeing a dialog

Reported by: therufa Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.6
Keywords: Cc:
Blocked by: Blocking:

Description

I discovered an error while developing a webapp that uses multiple modal boxes one above the other. Because every dialog is created with jquery dom the app removes each element after closing the dialog.

If the app generates multiple modal dialogs theres a bug: the overlay disappears from the dialog with the smallest z-index. So when I open a modal dialog from a modal dialog, then close the newly opened dialog and open a new one, jqueryui uses the overlay from the dialog beneath it.

I created a sample here: http://jsfiddle.net/LvTwf/1/

The html modal boxes work, the automatic generated ones not really.

Change History (2)

comment:1 Changed 9 years ago by Scott González

Component: ui.coreui.dialog
Resolution: duplicate
Status: newclosed

This has already been fixed: http://jsbin.com/iniyo4

Presumably a duplicate of #6645.

comment:2 Changed 9 years ago by Scott González

Duplicate of #6645.

Note: See TracTickets for help on using tickets.