Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6758 closed bug (notabug)

autocomplete: then type value by keys completely, select event do not issued

Reported by: opa Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.7
Keywords: Cc:
Blocked by: Blocking:

Description

I have value list (1,2,3,4)

When I type 2 and press tab or click on submit button. Value is inputed completely but select event do not issued

Change History (5)

comment:1 Changed 9 years ago by opa

onclose check INPUT value with menu and select if exists

comment:2 Changed 9 years ago by opa

and then i type unexisting case (menu is empty) mark input as .ui-state-error

comment:3 Changed 9 years ago by Scott González

Resolution: invalid
Status: newclosed

This is by design, the user hasn't explicitly selected a value. There's an extension that implements this.

comment:4 in reply to:  3 Changed 9 years ago by opa

Replying to scott.gonzalez:

This is by design, the user hasn't explicitly selected a value. There's an extension that implements this.

Thank you. Extension helped me.

Does it nice to have link to extension in widget documentation?

Extension also has a bug: It issues select event regardless changing of value. It is right use change event, not blur.

comment:5 Changed 9 years ago by Scott González

We can't possibly link to every single extension for every single widget, that would be insane to maintain and sort out the good extensions. Also, selecting has nothing to do with changing, you can select an item a million times before the change event even has a chance to be triggered. Any further discussion should happen on the forums.

Note: See TracTickets for help on using tickets.