Opened 9 years ago

Closed 7 years ago

#6898 closed bug (invalid)

Calling destroy on draggables causes orphans in IE8

Reported by: aws Owned by: aws
Priority: minor Milestone: 2.0.0
Component: ui.draggable Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

Test page: http://jsbin.com/upagi4/2/

I've linked to a pretty bare minimum example. The example turns two spans into draggables then calls destroy and remove on them.

If you open the test page with sIEve in IE8, when you click 'Run tests' followed by 'Remove tests' and open 'Show-in-use' in sIEve, you will see that the two spans that were turned into draggables then destroyed/removed are now 'orphans'. Orphans seem to essentially be a leak, as no matter how long sIEve is left open, they never seem to be reclaimed.

Change History (4)

comment:1 Changed 9 years ago by aws

I should have clarified that the test page is using jQuery 1.4.4 and jQuery UI 1.8.9, but that the problem also occurs with jQuery 1.4.3 and jQuery UI 1.8.0.

comment:2 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:3 Changed 7 years ago by mikesherov

Owner: set to aws
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! I can no longer reproduce the issue using the latest jQuery and jQuery UI. http://jsbin.com/upagi4/4/edit

If you can still reproduce it, please feel free to reply to this ticket with a test case showing the problem. Thanks!

comment:4 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.