Opened 9 years ago

Closed 9 years ago

#6911 closed bug (notabug)

autocomplete on a contenteditable div

Reported by: hm2k Owned by: hm2k
Priority: minor Milestone: 1.9.0
Component: ui.autocomplete Version: 1.8.8
Keywords: Cc:
Blocked by: Blocking:

Description

Although how to make jquery autocomplete to work for a contenteditable DIV instead of just INPUT, TEXTAREA fields has already been discussed and a workaround solution has come out of it, it is not a perfect solution.

I also came across a problem using this method and trying to use the date picker: http://jsfiddle.net/xvnaA/

It appears you can't have both.

So, perhaps Steve Jiang's solution of changing the autocomplete search method to accommodate contenteditable is the way to go.

What we are aiming for here is native support for autocomplete on a contenteditable div element.

Change History (3)

comment:1 Changed 9 years ago by Scott González

Owner: set to hm2k
Status: newpending

This isn't a bug. Perhaps you want to meant to file this as a feature?

comment:2 Changed 9 years ago by hm2k

Status: pendingnew

I would class unexpected behaviour as a bug.

IE: I would expect autocomplete to work on a contenteditable div element.

The bug is that, although it can (with a workaround), it conflicts with other behaviour such as datepicker.

A suitable solution would be to have native support for autocomplete on contenteditable div elements and it not conflict with anything else.

Version 2, edited 9 years ago by hm2k (previous) (next) (diff)

comment:3 Changed 9 years ago by Scott González

Resolution: invalid
Status: newclosed

Umm...the $.fn.val = $.fn.html solution was a joke. Doing that will break almost every single page that uses jQuery. The forum post even has descriptions of how this would really need to be done.

I'm closing this as invalid since autocomplete wasn't intended to work with contenteditable and the overview section of the docs specifically say that the plugin is to be used on an input. I've created a proper feature ticket: #6914.

Note: See TracTickets for help on using tickets.