Opened 10 years ago

Closed 10 years ago

#6915 closed bug (notabug)

Hover Icons not preloaded

Reported by: kingjeffrey Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.8
Keywords: Cc:
Blocked by: Blocking:

Description

It appears the hover-state icons are not preloaded. When hovering over the close icon for the first time, the icon disappears for a moment while the hover-state icon is downloaded. I assume this is a larger issue than just ui.dialog, but this is where I've confirmed it.

One solution is to combine all the normal, hover and active state icons into one file, so if there is a normal state icon displaying, it will necessarily download the hover and active state icons (since they are sprites in the same image).

Change History (1)

comment:1 Changed 10 years ago by Scott González

Resolution: invalid
Status: newclosed

This isn't actually a bug as this is purely a styling issue and you can use whatever styles you want. Since ThemeRoller themes aren't required (only the functional CSS, which contains no images, is required), this doesn't seem like something that should be tackled by anything in particular. Maybe core could generate elements with all possible states, though I don't know if all browsers will actually load the image if the element isn't visible. Feel free to start a discussion on the forum.

Note: See TracTickets for help on using tickets.