Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#6935 closed bug (duplicate)

Datepicker create event not being executed like other events.

Reported by: delwyn Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

Hi

The Datepicker does not seem to execute the create event as specified in the demo: $( ".selector" ).datepicker({

create: function(event, ui) { ... }

});

It works with all other events listed there.

Thanks

Change History (9)

comment:1 Changed 11 years ago by suner

I think I see the same issue using jQuery 1.4.4 and jQueryUI 1.7.3.

comment:2 in reply to:  1 Changed 11 years ago by Scott González

Status: newopen

Replying to suner:

I think I see the same issue using jQuery 1.4.4 and jQueryUI 1.7.3.

The create event didn't exist in any widget in 1.7.3.

comment:3 Changed 11 years ago by atistler

Nope, I see this exact same behavior as well. Using jquery 1.5.1 and jquery-ui 1.8.10.

comment:4 Changed 11 years ago by atistler

This is easy to reproduce:

1) Go to http://jqueryui.com/demos/datepicker/ 2) enter the following into firebug:

$('#datepicker').datepicker("destroy");

$('#datepicker').datepicker({

create: function(a,b) {

console.log("create");

}, onSelect: function(a,b) {

console.log("onSelect");

}, onClose: function(a,b) {

console.log("onClose");

}

});

"create" never gets logged.

comment:5 Changed 10 years ago by JGarrido

I'm experiencing the same issue; here I was able to reproduce it using jQuery 1.7.1 and jQueryUI 1.8.16: http://jsfiddle.net/jgarrido/u5rfc/

comment:6 Changed 10 years ago by strikernl

Still existing in 1.8.18. Why on earth is this not fixed yet? Either fix it or remove it from documentation!

Last edited 10 years ago by strikernl (previous) (diff)

comment:7 Changed 10 years ago by Scott González

Resolution: duplicate
Status: openclosed

comment:8 Changed 10 years ago by Scott González

Duplicate of #6228.

comment:9 Changed 10 years ago by strikernl

Ah I see; won't hold my breath then ;)

Note: See TracTickets for help on using tickets.