Opened 8 years ago

Closed 7 years ago

#6940 closed bug (worksforme)

Removing helper with link acting as link click in Chrome

Reported by: MiksIr Owned by:
Priority: minor Milestone: 2.0.0
Component: ui.draggable Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

<script>
$(function() {
  $( "ul li" ).draggable({ helper:"original", stop:function(event,ui) {
    ui.helper.remove();
  }});
});
</script>
<div style="width:100px;">
  <ul>
    <li><a href="http://www.google.com">google</a></li>
    <li><a href="http://www.google.com">google</a></li>
  </ul>
</div>

Test here http://jsbin.com/upilu4/3

Tested on 1.8.9 and current master.

No this bug in 1.8.0 (http://jsbin.com/upilu4/2)

Same trouble with droppable plugin if helper removed with ui.draggable.remove();

Change History (3)

comment:1 Changed 7 years ago by Scott González

Milestone: 1.9.02.0.0

comment:2 Changed 7 years ago by MiksIr

Tested today in last stable Chrome with last stable jquery ui - look like all work nice now.

comment:3 Changed 7 years ago by Scott González

Resolution: worksforme
Status: newclosed

I actually can't reproduce this even with 1.8.9. Perhaps something changed in Chrome?

Note: See TracTickets for help on using tickets.