Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#6965 closed bug (worksforme)

datepicker example does not put 'next' and 'prev' buttons next to current month

Reported by: SanderP Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

I just downloaded and installed a full jQuery UI install. The example includes a datepicker but it's not working correctly it seems. I want to include datepicker in my own website so for now it's the UI element I'm focused on. I copied snippets of the sample into a separate HTML file to try to narrow down the problem. That sample also doesn't work quite right.

Looks like I can't attach a screenshot so I'll try the describe the behavior. When I click in the textfield, the calendar appears. The problem is that the orange field with the current month and year first shows the 'prev' button, then on a new line the 'next' button and then on yet another line the month and year. With the examples online on your site these three should be on one line. If I hover over one of the buttons an extra line is added to the orange field which is then removed again, causing flickering. Clicking may or may not cause a month change, depending on how lucky you are.

This is with the latest Firefox 3 browser on Windows XP. IE shows a different behavior but also doesn't work right, the orange box is page wide.

Here's the code:

<html>

<head>

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> <title>jQuery datepicker Example Page</title> <link type="text/css" href="css/ui-lightness/jquery-ui-1.8.9.custom.css" rel="stylesheet" /> <script type="text/javascript" src="js/jquery-1.4.4.min.js"></script> <script type="text/javascript" src="js/jquery-ui-1.8.9.custom.min.js"></script> <script type="text/javascript">

$(function(){

Datepicker $('#date').datepicker(); });

</script>

</head> <body>

<h1>Datepicker example</h1> <input type="text" name="date" id="date" />

</body>

</html>

Thanks,

SAnder

Change History (4)

comment:1 Changed 8 years ago by Scott González

Resolution: worksforme
Status: newclosed

Please provide a demo.

comment:2 Changed 8 years ago by SanderP

The code runs on an intranet server so you don't have access, sorry. I don't have a public apache box to put this on. I could try to put it on a public IIS box but if that works I'm no closer to making it work where it matters.

Here's a screenshot:

https://picasaweb.google.com/sander.pool/JQuery#

As a fellow developer I'm disappointed you would immediately close/worksforme a ticket that was at least reasonably well written. It's a slap in the face. If you need more information you can ask for that without closing the ticket. I only logged this ticket because your ZOHO forums don't work on this machine, possibly because of IT enforced security, I don't know.

comment:3 Changed 8 years ago by Scott González

I really don't know what to tell you. From all available methods of testing, this works for me: jqueryui.com, jsbin.com, fresh download from the download builder, local checkout of master. The bug tracker is not a support group, so closing the ticket as worksforme is the correct thing to do. You'll notice that I did ask for a demo showing the problem. I didn't just close it and say, "I don't believe you." If you can't provide a demo, I can't provide any help.

comment:4 Changed 8 years ago by bkress

I am experiencing the same issue. Here is a jsfiddle link that reproduces it.

http://jsfiddle.net/bkress/R8YEa/

This is caused by not having the css classes for the datepicker present in your CSS file. More information: http://stackoverflow.com/questions/5031854/previous-and-next-buttons-are-displayed-on-new-lines-with-jquery-ui-datepicker in case someone stumbes across this with the same issue.

Last edited 8 years ago by bkress (previous) (diff)
Note: See TracTickets for help on using tickets.