Opened 9 years ago

Closed 7 years ago

#6987 closed bug (invalid)

Datepicker incorrectly shown during alt tab

Reported by: jcdekker Owned by: jcdekker
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

When you change the value of an input (that has a date picker) in the blur event, the date picker is suddenly shown and shown at an incorrect position when you put the focus back on the input using the alt tab key combination. This happens in both internet explorer as firefox (didn't test other browsers).

This bug is introduced in version 1.8.7 but still exists in version 1.8.9. In version 1.8.6. it runs as expected.

The following shows the code:

$('input.date')
 .datepicker(
      { dateFormat: 'dd/mm/yy', showOn: 'button', 
        buttonImage: 'Images/calendar.gif', buttonImageOnly: true 
  })
 .blur(function(event) {
   var target = formGetJavascriptEventTarget(event)
   jqTarget = $(target);
   jqTarget.val('1/1/2000');
});

Change History (4)

comment:1 Changed 9 years ago by jcdekker

I'm sorry, instead of alt tab i mean shift tab.

comment:2 Changed 7 years ago by Scott González

Milestone: 1.9.01.11.0

comment:3 Changed 7 years ago by mikesherov

Owner: set to jcdekker
Status: newpending

Thanks for taking the time to contribute to the jQuery UI project! I couldn't reproduce the issue using the latest versions of jQuery and jQuery UI: http://jsfiddle.net/eB4QT/2/

Please let me know if you have any questions, and if there is still a bug, please respond and let me know!

comment:4 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.