Opened 8 years ago

Closed 8 years ago

#6996 closed bug (worksforme)

Change year drop down list in IE 8

Reported by: Mbayes11 Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.datepicker Version: 1.8.9
Keywords: Cc:
Blocked by: Blocking:

Description

I am having an issue with the change year list. When I select a year in the list and then try and click on the list again to select another year, the list pops up that quickly goes away. After the list goes away if I am able to select the list the next time, but every time I make a selection the next time i try and click the list it bugs again.

Code highlighting:

var dates = $("#txtStartDate, #txtEndDate").datepicker({
                changeYear: true,
                changeMonth: true,
                onSelect: function (selectedDate) {
                    var option = this.id == "txtStartDate" ? "minDate" : "maxDate",
                                        instance = $(this).data("datepicker");
                    date = $.datepicker.parseDate(
                                        instance.settings.dateFormat ||
                                        $.datepicker._defaults.dateFormat,
                                            selectedDate, instance.settings);
                    dates.not(this).datepicker("option", option, date);
                }
            });

Change History (1)

comment:1 Changed 8 years ago by rdworth

Resolution: worksforme
Status: newclosed

I was not able to reproduce this issue using http://jqueryui.com/demos/datepicker/dropdown-month-year.html . If you have can reproduce, please share a minimal test case using jsFiddle or jsbin.

Note: See TracTickets for help on using tickets.