Opened 9 years ago

Closed 6 years ago

#7081 closed bug (duplicate)

datepicker positioning/rendering detection does not work properly if DP is inside a fixed div located at bottom of page and the page is long

Reported by: megamonk Owned by:
Priority: minor Milestone: 1.11.0
Component: ui.datepicker Version: 1.8.10
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by Scott González)

im trying to put a date picket inside a fixed div at the bottom of the page (facebook style mini nav).

ex:

<div style='position:fixed; bottom: 0'>
Date: <input type="text" id="datepicker">
</div>

if my page is short, the date picker is rendered above the field and inside the view port. but if the page is long the date picker is rendered outside the viewport and cant even be seen or partially seen. i think this has something to do with how the offsets are detected/computed. here is a sample of the full page which i edited from the demo to recreate the bug. try the date picker while you are on top of the page then try it when you scroll down let say at least in the middle of the page.

Change History (6)

comment:1 Changed 9 years ago by Corey Frang

Status: newopen

comment:2 Changed 9 years ago by Scott González

Description: modified (diff)

comment:3 Changed 8 years ago by kmudrick

I think this is caused by using document.documentElement.clientHeight instead of document.body.clientHeight in all of the offset computation code in the plugin

comment:5 Changed 7 years ago by Scott González

Milestone: 1.9.01.11.0

comment:6 Changed 6 years ago by tj.vantoll

Resolution: duplicate
Status: openclosed

Duplicate of #5626.
This was fixed in 1.8.22 and is a duplicate of #5626.

Note: See TracTickets for help on using tickets.