Opened 11 years ago

Closed 11 years ago

#7083 closed bug (notabug)

ui-helper-hidden-accessible not working correctly in IE6 or IE7

Reported by: Necroman Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.css-framework Version: 1.8.10
Keywords: Cc:
Blocked by: Blocking:

Description

When I use this class on a <button> element, in IE6 and IE7 the button is still visible like before. I modified the style and it is working now, but I'm not sure, if this can break usage od ui-helper-hidden-accessible elsewhere.

Original style:

.ui-helper-hidden-accessible { position: absolute !important; clip: rect(1px 1px 1px 1px); clip: rect(1px,1px,1px,1px); }

Note also the duplicate clip: rect(1px 1px 1px 1px); - that's a bug I guess

My version, working in IE6 and IE7:

.ui-helper-hidden-accessible { position: absolute !important; clip: rect(1px,1px,1px,1px); left: 999999px; }

Change History (3)

comment:1 Changed 11 years ago by Necroman

It actually works, I've just tried to isolate the problem and when using the original code, it is hidden in IE6 and IE7 too

clip: rect(1px 1px 1px 1px); clip: rect(1px,1px,1px,1px);

Please add at least some comment to the jqueryUI code why we need double declaration of clip: rect;

comment:2 Changed 11 years ago by Scott González

Component: ui.coreCSS Framework

The duplicate clip is not a bug, it's required for cross-browser support.

comment:3 Changed 11 years ago by Scott González

Resolution: invalid
Status: newclosed

Closing since the original reporter said it works.

Note: See TracTickets for help on using tickets.