Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7113 closed bug (worksforme)

Modal Dialog continously extends page in IE, v1.9m4

Reported by: mikato Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.dialog Version: 1.8.10
Keywords: Cc:
Blocked by: Blocking:

Description

This is for version 1.9m4! I can't select that. I didn't see any related bugs when searching oddly.

I just made a modal dialog. I noticed in IE that when it's opened, the page extends continously as evidenced by the vertical scroll bar shrinking. It just keeps lengthening. Doesn't happen in Firefox. I then tried the exact code of the modal dialog demo at http://jqueryui.com/demos/dialog/#modal-form with the same result. This seems to just happen the first time the dialog is opened on the page. Then I tried putting in the current 1.8.10 version of jquery ui and then it did not happen so I'm pretty sure this is a problem with the development version. I'm using the milestone releases for 1.9 since I need the tooltips.

Easy to reproduce. Just try the demo code I mentioned in IE8.

Change History (3)

comment:1 Changed 8 years ago by Scott González

Component: ui.coreui.dialog
Resolution: worksforme
Status: newclosed

This is working fine for me. Tested against master demo and 1.9m4 demo in IE 8 and IE 9.

comment:2 Changed 8 years ago by mikato

Try adding

body { position: relative; }

to the style. That's what I found to cause it after narrowing it down.

comment:3 Changed 8 years ago by Scott González

jQuery and jQuery UI don't support setting any dimension or position related styles on the body.

Note: See TracTickets for help on using tickets.