Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7117 closed bug (duplicate)

Option "aspectRatio" could not be changed after init (bugfix in the ticket)

Reported by: raziel057 Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.resizable Version: 1.8.10
Keywords: Cc:
Blocked by: Blocking:

Description

The problem is visible here: http://jsfiddle.net/HTcSx/

To fix this issue, I just added the following function in $.widget("ui.resizable") before _updateCache method.

_setOption: function( key, value ) {

this.options[ key ] = value; if ( key == "aspectRatio" ) {

self = this.element.data("resizable"); self._aspectRatio = !!(this.options.aspectRatio);

}

},

Could you correct it in the next release?

Change History (2)

comment:1 Changed 9 years ago by rdworth

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by rdworth

Duplicate of #4186.

Note: See TracTickets for help on using tickets.