Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7190 closed bug (duplicate)

Resizable-call hides the resizable control if 'display' is set to 'none'

Reported by: joerg.metzler Owned by:
Priority: minor Milestone: 1.9.0
Component: ui.resizable Version: 1.8.11
Keywords: Cc:
Blocked by: Blocking:

Description

Hi you JQuery-UI-Guys,

i got a bug with ui.resizable:

If a control (in my case a select (multiple)) is hidden (e.g. in a tab) then the call "$('#mycontrol').resizable(...)" creates a wrapper around '#mycontrol' with the size of zero.

Here is an example:

<!DOCTYPE html> <html lang="en"> <head>

<meta charset="utf-8"> <title>jQuery UI Resizable</title> <link rel="stylesheet" href="../../themes/base/jquery.ui.all.css"> <script src="../../jquery-1.5.1.js"></script> <script src="../../ui/jquery.ui.core.js"></script> <script src="../../ui/jquery.ui.widget.js"></script> <script src="../../ui/jquery.ui.mouse.js"></script> <script src="../../ui/jquery.ui.resizable.js"></script> <link rel="stylesheet" href="../demos.css"> <style>

.ui-resizable-se {

bottom: 17px;

}

</style> <script>

$(function () {

$("select").resizable({

handles: "se"

});

});

function makeTheSelectDivVisible(){

$('#theselectdiv').css('display', 'block');

}

</script>

</head> <body> <input type="button" id="thebutton" onclick="javascript:makeTheSelectDivVisible();" value="click me to make the select visible" />

<div class="demo" style="display: none" id="theselectdiv">

<table>

<tr>

<th>

select

</th>

</tr> <tr>

<td>

<select multiple="multiple" size="4" style="width: 250px">

<option>test1</option> <option>test2</option>

</select>

</td>

</tr>

</table>

</div>

</body> </html>

Change History (2)

comment:1 Changed 8 years ago by rdworth

Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by rdworth

Duplicate of #6230.

Note: See TracTickets for help on using tickets.